CPIでComposer を使う場合はバージョンの指定が必要です
○ → php-7.0
× → php (コマンドがないと怒られる)

 

上記内容を踏まえて

curl -sS https://getcomposer.org/installer | php-7.0

ネットに良く載っているのは

curl -sS https://getcomposer.org/installer | php